[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cache directories


I'm trying to fix tarsnap service on NixOS[1] and I have several
questions regarding cache directories.

As experimentally discovered in [1], tarsnap breaks when using separate
cache directories. I'm not yet sure if this is an intended behavior or
we do something the wrong way. A short summary of the problem:

1. User (me) has several tarsnap configurations with different cache
directories and one common key file.
2. Run `tarsnap --fsck` for configurations foo and bar;
3. Run `tarsnap -c --configfile foo`, observe that it works;
4. Run `tarsnap -c --configfile bar`, observe that it fails;
5. Run `tarsnap --fsck --configfile bar`;
6. Run `tarsnap -c --configfile bar`, observe that it works now;
7. Run `tarsnap -c --configfile foo`; observe that it's broken.

The error in all cases is "Sequence number mismatch". From that I can
conclude that tarsnap doesn't support separate cache directories -- is
it correct?

Generally, our NixOS module supports creating several tarsnap
configurations with different key files and other settings, which are
given separate cache directories. The first fix that I thought of was to
instead use one common cache directory. But what if a user has
configurations with different keys? Is it okay to use the same cache
directory in this case?

One last thing -- when I run tarsnap given an empty cache directory, it
fails. Do I understand correctly that if I want to use a cache
directory, I should first run `--fsck` on it to fill it for the first time?

Last but not least, I want to use this chance to thank Colin and tarsnap
contributors for their awesome work on this product. You are the best!


1: https://github.com/NixOS/nixpkgs/issues/15948