[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Partial file, .part, not present during failed large upload due to negative funds

> On Sep 2, 2018, at 2:36 PM, Colin Percival <cperciva@tarsnap.com> wrote:
> On 9/2/18 12:18 PM, Justin H Haynes wrote:
>> I ran into a problem after I ran out of funds in my account, and the backup
>> stopped.
> Hmm, that's odd.  Did you see an error message to that effect, or are you
> just assuming that was the cause?  Running out of funds shouldn't normally
> result in an archive being interrupted.
I assumed that was the cause.  It was not.  Also I notice my tmux session was ended.  I guess I fatfingered something and likely killed the session and the jobs in the shell, one of which was Tarsnap.

>> Did I lose my backup in progress, or can I continue the backup and know that
>> the first archive will appear without having to re-upload all the files?
> If you start creating another archive, the first archive should appear as a
> partial archive.  This hasn't happened yet because the tarsnap server doesn't
> know that the client died -- for all it knows the client might just be busy
> chewing on duplicate data and not need to upload anything yet.
OK this is good to know.  I am creating another archive of the same folder and will monitor to see how long it takes.  I expect it will finish in the next couple of days.

>> Today, I added 100 to the account so that the balance would be over 92
>> dollars.  The last daily storage charge was for 184245293378 bytes (just under
>> 184 GB) of storage.  Based on my .tarsnaprc file which has "checkpoint-bytes
>> 1G” defined, I would expect to find a .part file totaling 183GB.  However, I
>> don’t find anything when I run the following command:
>> $ pwd
>> /usr/home/justin
>> $ id
>> uid=1001(justin) gid=1001(justin) groups=1001(justin),0(wheel)
>> $ tarsnap -vv --list-archives
> Right, the .part archive is only created when it becomes apparent that a
> previous archive failed.  In fact, it's created by the client, using
> checkpoint data stored in the tarsnap cache directory -- what do you have
> in /home/justin/tarsnap-cache ?
Now there are several hundred mb in a couple of files. 

> -- 
> Colin Percival
> Security Officer Emeritus, FreeBSD | The power to serve
> Founder, Tarsnap | www.tarsnap.com | Online backups for the truly paranoid