[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Odd thing about restore times

Hi Bob,

Thanks for your reply.

On Sat, 2018-11-24 at 09:48 +0000, Bob Eager wrote:
> On Fri, 23 Nov 2018 17:35:06 -0800
> Craig Hartnett <craig@1811.spamslip.com> wrote:
> > In all test cases I used the following command:
> > 
> > 	tarsnap -x -f ARCHIVE media/USER/PATH/DIRECTORY
> > 	tarsnap -x -f ARCHIVE
> > 

> I am guessing to some extent, but I would imagine that tarsnap is
> scanning to see if there is a more recent version of the file in the
> same archive (this is possible with tar, anyway, and I suppose that if
> you give the two names to tarsnap it will do the same).
> I wonder what happens if you use:
>   tarsnap -x -k -f ARCHIVE media/USER/PATH/DIRECTORY

Your reply made me try the following:

        * Same command as original email and same result: instant
        restore but 16 minutes for the command to exit.
        * Turns out that even though the file has not changed on my
        localdisk, I can still recover it when specifying a newer
        archive. Good to know. Same result though: instant restore but
        16 minutes for the command to exit.
        tarsnap -x -k -f INITIAL-ARCHIVE
        * Your suggestion. Same results: instant restore, also 16
        minutes for the command to exit.

Admittedly these were all running in parallel at one point, but only
after the previously executed command had been running for 5 minutes in
one case and 10 minutes in the other. I need to go to bed!

In case it's pertinent, Xubuntu 14.04.