[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Tarsnap Cache Issue in WSL

I ran into a problem I cannot seem to solve. I use WSL on the latest version of Windows 10 and Ubuntu 20.04 LTS. I recently upgraded my host, so I had to reinstall Tarsnap on WSL. I am running Tarsnap as root, and I am trying to create an archive. In my tarsnap.conf file I set my cache directory to be in /root.
I am getting an error message that say's the following: "tarsnap: link(/root/tarsnap-cache/directory.tmp, /root/tarsnap-cache/directory): Permission denied"

I made sure permissions were set correctly on the tarsnap-cache directory (I have tried full rwx to everyone), and I have tried the default location in /usr/local/; none of this has worked and I get the same error message.

I made a second keyfile, but I have also tried to reuse my keyfile from before I upgraded my host but that didn't seem to work in creating an archive either; it let me extract from archives though.

I am using the basic command: sudo tarsnap -cvf "BACKUP_NAME" /mnt/c/Users/[USER]/Documents/tar-backup

I am at a loss as to why this is happening and I would greatly appreciate any help.

Brendan K.